注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

江志祥的博客

可恶的中国银行,信用卡像病毒啊,取消那么难,,,

 
 
 

日志

 
 

Invalid library (maybe not a PHP library) 'gettext.so'  

2012-05-12 19:57:39|  分类: 计算机-php |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

今天给php安装扩展包 gettext的时候,出现了如标题所显示的错误。

根本原因:版本不一致

背景:

今天开始一个国际化的项目,要使用 php的 gettext实现多语言,但是,当前项目的php源文件已经没有了(版本是 5.2.14)。于是我从自己的开发机的php源文件中,进行了gettext文件的获取(版本不是 5.2.14)。

执行过程如下:

我的开发机的php安装目录是/home/work/php5/

1) 进入php源码文件的lib/ext/gettext目录。

2) 在 gettext目录,执行 phpize。

3)在gettext目录,执行 ./configure --with-php-config=/home/work/php5/bin/php-config

4) 在 gettext目录,执行 make && make install

5)获得 生成的so文件: gettext.so

6)然后将 gettext.so 复制到目标项目的 extension_dir(在php.ini文件中)所指定的目录中

7)修改 php.ini文件, 添加一行 extension=gettext.so

 

修改问题方式:只要版本相同,安装以前7步即可完成。

  评论这张
 
阅读(1195)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017